Outbound SMS DLR Issue
Incident Report for Plivo
Resolved
The incident has been resolved. DLRs for all new messages will be processed without delay.
Posted May 17, 2018 - 17:36 UTC
Investigating
We are seeing elevated failures in updating DLRs for outbound SMS. We are investigating.
Posted May 17, 2018 - 16:30 UTC