Call failures on inbound voice and inbound sms delivery delay towards few areas in US (Rochester, St. Cloud, Billings, Fargo, Cheyenne)
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted Nov 16, 2019 - 16:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2019 - 13:51 UTC
Identified
Our carrier partner is observing minor inbound voice call failures and inbound regular sms towards phone numbers in the US(Rochester, St. Cloud, Billings, Fargo, Cheyenne). A small percentage of phone numbers may experience call failures.

We're actively working with our carrier partner to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions.
Support portal: https://support.plivo.com/support/home
#175623
Posted Nov 16, 2019 - 11:21 UTC
This incident affected: Phone Numbers.