10DLC Campaign Registration Failures: United States
Incident Report for Plivo
Resolved
This incident has been resolved.
Posted May 19, 2022 - 09:11 UTC
Investigating
Dear Valued Customer,

Our campaign registry partner is experiencing failures in registering new campaigns. This may impact any new campaign registrations under 10DLC towards the United States.
Users might encounter issue when linking numbers to their 10DLC campaign.Existing campaigns will not face any problems.

We are actively working with our carrier partner to get this issue resolved as soon as possible.

Please contact Plivo Support for any questions. Support portal: https://support.plivo.com/support/tickets/new
#90016
Posted May 19, 2022 - 08:47 UTC